Honda CR-Z Hybrid Car Forums banner
61 - 80 of 84 Posts

·
Registered
Joined
·
536 Posts
I highly doubt it will resolve on it's own in August.

If it is the signed 32 bit integer problem the year will still be 2022 and the value will still be negative.

If it is the GPS 1024 week rollover it will only be 28-29 weeks in from zero? I don't see how that would fix the issue. 32 weeks might be significant but I won't hold my breath.
 

·
Registered
Joined
·
13 Posts
I'm glad I'm not the only one with this problem. I actually thought I was going crazy since it wasn't changing lol. Is there some kind of website we can complain to Honda?
 

·
Registered
Joined
·
8 Posts
So it looks like the issue will "fix" itself in August according to the article:
https://jalopnik.com/honda-clocks-are-stuck-20-years-in-the-past-and-this-mi-1848306970
This would line up with my theory that there's a bit of code which checks if the date is before a certain year and resets to 2002 if it's outside of certain parameters. In August the GPS will reporting it's 2003 (the exact date would be August 17 2022, 1024 weeks before that date is 1st Jan 2003). If the year check is 'is the date before 2003 then error' then it will solve at least the time issue. Auto summer time is going to be broken forever though as it still won't have the correct date.

I've actually been trying to reverse engineer the firmware on the nav units to confirm this, and maybe look into the possibility of removing these checks. So far i've managed to build a picture of how the system works with each of it's modules, but i've not yet found the GPS time processing function. I can see that the clock itself is managed by HMIManager.dll but that has no error handling in that i can see. If i find anything then i'll be sure to report back :)
 

·
Registered
Joined
·
88 Posts
Yea this exact issue happened to me as well. Noticed it isn't updating when connecting to my phone and just shows Jan 1st 3pm
 

·
Registered
Joined
·
16 Posts
I've had my 2011 CR-Z for six months and the clock has stopped functioning I have the 2011 unit with GPS. It ether shows the same time or sometimes shows the time at which I last started the car. I went into clock settings but there didn't seem to be a place to do anything about this problem. Does anyone have any ideas on how to fix this.
 

·
Registered
Joined
·
536 Posts
I've had my 2011 CR-Z for six months and the clock has stopped functioning I have the 2011 unit with GPS. It ether shows the same time or sometimes shows the time at which I last started the car. I went into clock settings but there didn't seem to be a place to do anything about this problem. Does anyone have any ideas on how to fix this.
 

·
Registered
Joined
·
1 Posts
I also in Italy here in Naples I had the same problem. In my case, every time I start the clock it restarts from 2:00 which would be 0:00 + 1 time zone +1 summer time, which are set ON by default.
I would certainly like to read here if anyone knows what kind of response Honda is going to give. Surely all our vehicles are out of warranty, but an error of this type is very serious since it is a very computerized machine and I expect a solution to the problem from an important manufacturer like Honda that can certainly be achieved in various ways. I too will share it with you as soon as I have news
 

·
Premium Member
Joined
·
7,970 Posts
Summary, all will be affected if you have a 2010-12 Navigation OEM radio. There is no easy fix right now. Summary of all of the above is it will require either a change from Honda or some kind of a firmware or programming update. This is worldwide affecting all factory radio GPS units of that vintage of all brand vehicles.

Due to age of the vehicles I highly doubt there will be a solution from Honda or any other car manufacturer. Someone maybe able to reverse engineer it but you can spend a lot of time and maybe money doing that but could just get something better aftermarket you can have shipped to you today. Start shopping for an after market radio or GPS unit. Either can be had for not very much money.

More Obsolete technology. We just watched Black Berries get killed and there is about to be all CDMA/3G cellphones to also stop working. They are already not supported. Nothing lasts forever.
 

·
Registered
Joined
·
16 Posts
first of all its relief knowing I am not the only one with the issue, I was about to go crazy with this. Second it affects so many cars in the Honda lineup that I believe there will be a fix... but i read in the article shared that in August it will fix itself.. if not well then maybe swap for another unit... android I guess my main issue is the phone by Bluetooth that's something that I need a lot
 

·
Premium Member
Joined
·
7,970 Posts
Most aftermarket radios have both phone and audio streaming through Bluetooth it is a common feature now. Go look in the threads on that here. There are many options and many have back up cameras too all for very little money just need to get the connection parts and follow directions or if you have to have it professionally installed.

first of all its relief knowing I am not the only one with the issue, I was about to go crazy with this. Second it affects so many cars in the Honda lineup that I believe there will be a fix... but i read in the article shared that in August it will fix itself.. if not well then maybe swap for another unit... android I guess my main issue is the phone by Bluetooth that's something that I need a lot
 

·
Registered
Joined
·
5 Posts
Can confirm, still affecting more drivers every day. I have the Nav model and I thought that unit was gone as my map location isn't working either.
I initially thought this was a battery issue but after exploring online, it seems lots of people are affected.
 

·
Premium Member
Joined
·
7,970 Posts
See above you are not the only one! 2010-12 CR-zs and many other models and brands also affected. we have had over 74 answers and over 2K looks. It is a World wide issue! It happens every Epoch according to the other articles I saw. Similar has happened at least 2 other times. Here are just 2 of the recent articles .


The new year it appears my clock keeps resetting to 1.00 pm/am?
I googled it and found this:
Honda owners left baffled after glitch leaves the clocks on their car stuck 20 years in the past | Daily Mail Online
 

·
Registered
Joined
·
3 Posts
Hi here from Italy. Same problem. Someone contacted Honda Europe to make them aware of the problem?
I called Honda Italy and they said they don't know anything about the problem...
 

·
Registered
Joined
·
334 Posts
Hi here from Italy. Same problem. Someone contacted Honda Europe to make them aware of the problem?
I called Honda Italy and they said they don't know anything about the problem...
That's unlikely, it's a global issue affecting Hondas across many models and years so they have to know about it. But it doesn't really matter since there is no fix other than to wait for August when it may fix itself and that probably isn't changing for CRZ owners.
 

·
Registered
Joined
·
8 Posts
Hi here from Italy. Same problem. Someone contacted Honda Europe to make them aware of the problem?
I called Honda Italy and they said they don't know anything about the problem...
I‘m from Germany and I was about 3 days after new year at my dealer to ask if it is only my problem.

In my case first I was thinking I made any mistake because I swapped that Nav-unit in my non Nav model. I was a little bit “happy” when the mechanic said they know about it and they’ve got an other customer which got the same issue in his CR-V.
He said that there are many other dealers in Germany which got those issues with the Nav-Unit.

I wrote to Honda Germany an Email, and they wrote back that it is an known problem and they are looking for a solution.
Sorry for my question if it’s still Answered but does anyone know if the problem is on 13-15 ZF2 or the 16 final ZF2 too?
 

·
Premium Member
Joined
·
7,970 Posts
so far only 2010-2012. @litz who has a 2013 reported above his is working fine.

I‘m from Germany and I was about 3 days after new year at my dealer to ask if it is only my problem.

In my case first I was thinking I made any mistake because I swapped that Nav-unit in my non Nav model. I was a little bit “happy” when the mechanic said they know about it and they’ve got an other customer which got the same issue in his CR-V.
He said that there are many other dealers in Germany which got those issues with the Nav-Unit.

I wrote to Honda Germany an Email, and they wrote back that it is an known problem and they are looking for a solution.
Sorry for my question if it’s still Answered but does anyone know if the problem is on 13-15 ZF2 or the 16 final ZF2 too?
 
61 - 80 of 84 Posts
Top