Honda CR-Z Hybrid Car Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,062 Posts
I found this on other forum:
“Since the clock always seemed to reset to exactly 1:00 when the battery was reconnected ... I simply disconnected power one night and the next day, at 12:59 p.m. reconnected the terminals ... and bingo ... my clock read 1:00! Problem solved.”
But the Nav units get their time from the GPS signal.
 

·
Registered
Joined
·
1,062 Posts
Anyone with working and not working Nav units care to post up their software versions?

1. Turn on ignition and allow navigation system to complete the start-up sequence
2. Press the INFO button on the touch screen
3. Select SYSTEM/DEVICE INFORMATION on the touch screen

Let's get some data collection. See if the 2021 map update is the solution. The other Honda/Acura models with the same Nav units don't seem to be fixed with the 2021 maps.
 

·
Registered
Joined
·
1,062 Posts
'i bet its gone back in time by 1024 weeks'...
Also a great observation.

Two competing theories, both valid. Maybe we are seeing a difference between UK and US Nav units?

Seems not everyone is seeing the May date but everyone seems to be getting the 2002 date.

But if it is a 32bit integer going negative then 2002 doesn't make sense. Maybe it is both issues at the same time?
 

·
Registered
Joined
·
1,062 Posts
I wonder if it was a New Year glitch. My 2011 just did the same thing. Thinking about disconnecting the battery and then reconnecting it, then entering the reboot code you have to enter to see if that cures the problem. Thoughts or any other suggestions?
Can't hurt, but not likely to fix this issue. This seems to be a programming issue that will come back as soon as the clock updates from the GPS signal.
 

·
Registered
Joined
·
1,062 Posts
I highly doubt it will resolve on it's own in August.

If it is the signed 32 bit integer problem the year will still be 2022 and the value will still be negative.

If it is the GPS 1024 week rollover it will only be 28-29 weeks in from zero? I don't see how that would fix the issue. 32 weeks might be significant but I won't hold my breath.
 

·
Registered
Joined
·
1,062 Posts
I've had my 2011 CR-Z for six months and the clock has stopped functioning I have the 2011 unit with GPS. It ether shows the same time or sometimes shows the time at which I last started the car. I went into clock settings but there didn't seem to be a place to do anything about this problem. Does anyone have any ideas on how to fix this.
 
1 - 8 of 8 Posts
Top