Honda CR-Z Hybrid Car Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

I have a 2016 crz EX and since I connected my new pixel 5 to the bluetooth, it plays just fine but the display just says "no device connected" and won't display the title, author, album like it is supposed to (and did with my previous phone). Because of this, the media control isnt working, for example I can not skip songs using the channel + button on my steering wheel.

Interestingly though when I get a phone call it displays that information just fine, and like I said before, any music or audio I play does output just fine.

Any tips? Thanks in advance

tried: restarting phone, restarting car, unpairing and repairing the bluetooth connection
 

·
Registered
Joined
·
2 Posts
Hello,

I have a 2016 crz EX and since I connected my new pixel 5 to the bluetooth, it plays just fine but the display just says "no device connected" and won't display the title, author, album like it is supposed to (and did with my previous phone). Because of this, the media control isnt working, for example I can not skip songs using the channel + button on my steering wheel.

Interestingly though when I get a phone call it displays that information just fine, and like I said before, any music or audio I play does output just fine.

Any tips? Thanks in advance

tried: restarting phone, restarting car, unpairing and repairing the bluetooth connection
Just a thought to eliminate from the list of potentials, is your firmware up to date on your phone? Is there even a way to update the software the car uses?

I’m a CRZ newbie, and I love my ride! I bought a 2014 CRZ Base Manual back in August. Thanks for letting me offer a thought. I hope you find the issue!
 

·
Super Moderator
Joined
·
6,638 Posts
The CR-Z was marginal for Blue tooth compatibility to begin with . Honda supported iPhones more than android and not carplay. It is now 10 year old technology and the phones have moved on as it worked with old phone but not new the radio is working as designed it just does not recognize all the new features of your new phone ( new version of blue tooth or phone software) you have a 2016 that was the last year a CR-Z was made and the radios were unique to that year all were touch screen and many changes were made to interior and exterior parts. It sounds like the radio sees the phone just does not display information from the phone on the radio. You have several choices :Live with it , get a different phone, replace radio, use Auxiliary cable instead of blue tooth but you said you get the audio and all rest of the phone functions with radio work just no content display so auxiliary cable will not solve issue.

Contact google and ask if they have a special update for Honda Cars of that year or CR-Zs specifically. You may need to down grade the blue tooth or software on that phone to the older version to be compatible with the radio and car.
 

·
Registered
Joined
·
1,587 Posts
@Spdbump is probably on the right track. New phones often run into compatibility errors on older cars. and you might end up having to just live with it.

You might have a security setting on the phone prohibiting the car from controlling your phone, so double-check that too. At least it's playing the music though... better than nothing.

good luck.
 

·
Registered
Joined
·
48 Posts
I have a 2016 EX-L and my Samsung S10+ works fine streaming music using bluetooth. Screen shows the songs and i can use the steering wheel controls to change music. So it must be your phone.
 

·
Registered
Joined
·
2 Posts
I stumbled upon this post while trying to address the same issue, but for my 2016 HR-V. And I have a Pixel 3.

Until last week, whenever the phone and car were connected via bluetooth it worked normally - there were player controls on the media centre screen and it displayed the title of the song / media. My phone received a system update last week, and now I have exactly the situation you describe.

It says "No Device Connected" on the BT screen - but the icons are there showing the phone battery level and signal strength. And when they connect, it says "Pixel 3 Connected." Music, phone, and text messages all come through properly but there is the persistent and frustrating "No Device Connected" message, and more annoyingly, I cannot control the media except via the phone.

Google had me do a factory reset of both the car and the phone and re-set up from scratch and it didn't fix the issue, so they are recommending a warranty replacement of the phone which seems extreme, and unlikely to help the issue if it was indeed a software update.

I really hope someone can find a solution to this.
 

·
Super Moderator
Joined
·
6,638 Posts
The issue is the update cannot be reversed and you were forced into an update but the equipment in your car does not recognize. Newer is not always better when it comes to firmware / software. You need to down grade ( which is not possible) and never allow it to upgrade. This will become more common with over the air software upgrades like on Tesla and other cars. You no longer own your devices.

Google caused the issue and you need to ask them how to downgrade but I bet the answer will be there is no way.:mad:
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
Having same issue as above. This worked! So glad, was driving me crazy.
 

·
Registered
Joined
·
2 Posts
This 100% fixed my issue, thank you so much for your help. I would not have thought to look there and was tearing my hair out.

Meanwhile, Google is still encouraging me to pursue a warranty replacement. Guess I won't be relying on them for support again.

Best,
R
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
Thank you so much! I was absolutely losing my mind on this. (yes, I 100% joined this forum solely out of aggressive thankfulness)
 

·
Registered
Joined
·
1 Posts
Thank you! I love my 2016 CR-Z but these past few weeks the lack of song controls have been driving me nuts and I tried resetting both my Pixel 4a and radio. Not to hijack the thread but has anyone found an Android Auto head unit that supports Lanewatch on the 2016s?

@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
Went through the trouble of registering just to say THANK YOU @iRob
This fixed my issue with my 2015 Honda Fit and Pixel 2xl (Android 11) and Pixel 4a(5g) (Android 11) Edit: Remember to reboot the phone after the change
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
I am forever indebted to whomever figured this out. This was such a frustrating problem and as shown above the solution is not one that you can even stumble upon.
 

·
Registered
Joined
·
1 Posts
Thank you so much, RedKangaroo!
I too became a member just to say "Thank you." I have a 2016 HRV and my phone is Pixel 3a. This issue was driving me crazy, and I tried so many different things. I even downloaded a few different music player apps to see if it would fix the problem. Nothing worked... Now, I've changed my phone's Bluetooth version to 1.3 and it's back to normal! The song information is displayed on the screen and I can use the remote control on the wheel to skip/go back songs.

By the way, my HRV's Smart Entry System indicator comes on sometimes. It was on for a few days and turned off on its own last week. Then yesterday as I was trying to figure out the above Bluetooth audio problem, the indicator came on again and it's still on right now. The car starts fine and there is no problem locking and unlocking doors. I changed my key fob battery so I know it's not the problem. Does anyone have the same issue?



@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
 

·
Registered
Joined
·
1 Posts
I stumbled upon this post while trying to address the same issue, but for my 2016 HR-V. And I have a Pixel 3.

Until last week, whenever the phone and car were connected via bluetooth it worked normally - there were player controls on the media centre screen and it displayed the title of the song / media. My phone received a system update last week, and now I have exactly the situation you describe.

It says "No Device Connected" on the BT screen - but the icons are there showing the phone battery level and signal strength. And when they connect, it says "Pixel 3 Connected." Music, phone, and text messages all come through properly but there is the persistent and frustrating "No Device Connected" message, and more annoyingly, I cannot control the media except via the phone.

Google had me do a factory reset of both the car and the phone and re-set up from scratch and it didn't fix the issue, so they are recommending a warranty replacement of the phone which seems extreme, and unlikely to help the issue if it was indeed a software update.

I really hope someone can find a solution to this.
Damm I had the same phone( pixel 3)and the exact same thing happened to my 2015 si when I updated the phone and to make it worse I jus got the pixel 5 this week And the same issue exist
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
Dude, you deserve a gold medal, it worked on my pixel 3 xl with the lastest android version. You are awesomeeeeee!!!!
 

·
Registered
Joined
·
1 Posts
@iRob I've been searching around as I've come across the same problem but for my 2016 Honda Fit EX. I also have a Pixel 3a.

It is indeed an issue with the most recent update to Android 11.

Luckily, I did find a solution (at least for now)! There was a Reddit thread in r/Pixel3a from about a year ago where someone had the same issue. There was a change to the bluetooth settings with the update that is causing the issue, so you just need to set it back to a previous version. I'm not sure if I'm able to link the post here, but I'll copy their directions below:

SOLUTION:
  1. Enable Developer Mode
    1. Settings
    2. About Phone
    3. Find Build Number at the bottom and tap on it 7 times.
    4. Enter passphrase (if applicable)
  2. Change Bluetooth AVRCP Version
    1. Settings
    2. System
    3. Advanced
    4. Developer Options
    5. Under "Networking", change Bluetooth AVRCP Version to "AVRCP 1.3" (normally it is set to "AVRCP 1.5 (Default)")
  3. Re-Add the phone to the car's Bluetooth
    1. You may need to delete your phone from the car's Bluetooth system. I didn't but you might try it if needed.
    2. Re-Add the phone to the car's Bluetooth system
    3. (my note here: You will probably need to reboot your phone for the changes to take effect-- I did.)
I hope this helps you all out! It seems to have fixed the issue for me, so hopefully it can be changed again with future updates to the phone's software.
THANK YOU SO MUCH!!!
 

·
Registered
Joined
·
1 Posts
I joined this forum just to say a huge Thank You! Lifesaver. It was driving me nuts to not be able to skip songs using steering wheel controls. You are a hero
 
1 - 20 of 22 Posts
Top