Honda CR-Z Hybrid Car Forums banner

181 - 200 of 217 Posts

·
Registered
Joined
·
1 Posts
Jumping into this thread to say that I've had very similar symptoms (couldn't check error codes because I lost my OBD scanner), except I've never heard the fans come on, ever.

I considered DIY-ing it ([DIY] IPU fan Code P1643 and P1448) but decided against it because I technically can't confirm if it's actually a P1448 and/or P1634 code.

Brought it into the dealership and they're quoting me $1500 for both the MCM module and labor, they're saying that one of the previous owners (I'm the 3rd owner) installed some janky extra wires in there and so the 15/150 warranty doesn't cover it (I'm in the Northeast).

By any chance, does anyone know how much the MCM module would cost and/or where to get it, and how easy it would be for me to fix it?
 

·
Super Moderator
Joined
·
6,854 Posts
Did that dealer tell you what they found? Per Magnuson Moss Warranty law they cannot invalidate your warranty unless they can prove that whatever was done was a directly connected part of the issue. The modifications have to be proven to be the root cause of the issue they can't blame an unrelated part. They will try but they have to prove that that was the root cause. Go somewhere else where they do not tell you a huge number before fully diagnosing the car.

We have had reported here a lot of very high numbers before they even looked at the car they either don't have the training and knowledge or they are just trying to bleed your wallet dry. One UK member was told the fan was an integrated part of the battery and could not be replaced. Because she was stranded she sold them the car and bought a new one. Another member was told $3k and was never given a diagnosis and he too got rid of his CR-Z. Not all dealers are honest or want to fix issues they just want to sell cars. Know your rights and get government agencies involved if you have to . You have a warranty you should be able to use it unless the previous owners made major modifications to the affected system(s) (IMA?). We have seen no modifications to IMA other than to remove it as part of a K swap.

You can borrow an OBD II scanner from many auto places or they will read the codes for you for free. You can research prices for parts once you determine what has failed by using https://www.hondapartsnow.com/. Code never = part always follow the correct trouble shooting in the Factory service manual. The FSM is posted on this forum as a .PDF for all years prior to 2012 or you can purchase one from here 2011-2012 CR-Z Service Manual $150.00

I have only heard my fans the first years I owned the car and have asked multiple dealers to check them and they tell me they are working properly . Even when I was in Texas!:(

If you have wiring issues you may want to very carefully remove any wires that were installed and try to return the wiring back to OEM or as OEM as possible ( remove crimps, solder and heat shrink etc )to increase the reliability of the vehicle and prevent fires and dead on road issues where no shop will touch it. If you can't do the work yourself you may need an independent electrical specialist.

Jumping into this thread to say that I've had very similar symptoms (couldn't check error codes because I lost my OBD scanner), except I've never heard the fans come on, ever.

I considered DIY-ing it ([DIY] IPU fan Code P1643 and P1448) but decided against it because I technically can't confirm if it's actually a P1448 and/or P1634 code.

Brought it into the dealership and they're quoting me $1500 for both the MCM module and labor, they're saying that one of the previous owners (I'm the 3rd owner) installed some janky extra wires in there and so the 15/150 warranty doesn't cover it (I'm in the Northeast).

By any chance, does anyone know how much the MCM module would cost and/or where to get it, and how easy it would be for me to fix it?
 

·
Registered
Joined
·
2 Posts
hi guys..one of my friend own ZF1 2013 have issue trouble with IMA..some alert show on his dashboard disply:
- IMA system halte
-6 IC on motherboard is burned
-IMA integrated motor assist
is IMA can fix it or must be replace it? is anybody can help me ? please text me on whatsapp +62 81210028478 or [email protected],very appreciate for advice and assist
 

·
Registered
Joined
·
604 Posts
Sorry I'm not using whatsapp or e-mail. You will have to post the information here for us to view and discuss.

We need a lot more information, some good quality pictures of the damage, and the full diagnostic error codes from an HDS clone tool.

How did it happen?
What exactly happened?
What have you done to try and fix it?

I appreciate English might not be your first language, but we will try to help if possible.
 

·
Registered
Joined
·
32 Posts
63763

I got a IMA Checklist message in my honda crz 2012 model automatic transmission.

What could be a possible solution for the above issues. Any idea????.
 

·
Registered
Joined
·
604 Posts
We need the IMA codes and a lot more background info for a reliable diagnosis.

What happened, when, symptoms, etc etc, etc..

Your local garage, or a suitable OBDII tool, HDS clone can read the codes.
 

·
Registered
Joined
·
32 Posts
We need the IMA codes and a lot more background info for a reliable diagnosis.

What happened, when, symptoms, etc etc, etc..

Your local garage, or a suitable OBDII tool, HDS clone can read the codes.
I have not checked yet with my local garage yet. I just a check light today. Mileage is 115000km.

From you knowledge or experience what could be a possible problem to deal with IMA.
Is it a fuse, wiring or IPU fan problem,,,, etc.....any idea?
 

·
Registered
Joined
·
32 Posts
It could be anything in the attached list at this stage..
Let my technician come tomorrow and see what codes im getting through diagnostic

Could it be 12v under the hood battery making issues to IMA. Last 12V Battery was changed at 84,000km. Now the mileage is 115,000km.
 

·
Registered
Joined
·
280 Posts
Could it be 12v under the hood battery making issues to IMA. Last 12V Battery was changed at 84,000km. Now the mileage is 115,000km.
I am no IMA expert, but I have read many times here that a bad 12V battery can cause warning lights. So it could be worth a check!
 

·
Super Moderator
Joined
·
6,854 Posts
Don't even bother testing it just replace it. Normally the low battery triggers not just the IMA light you will have the ABS, Hill control and check engine lights, etc.

There are many threads about that light turning on and you could have added to any of those threads.

As @PeterPerkins stated in order for any of us to assist you you need to provide more details.

Let my technician come tomorrow and see what codes im getting through diagnostic

Could it be 12v under the hood battery making issues to IMA. Last 12V Battery was changed at 84,000km. Now the mileage is 115,000km.
 

·
Registered
Joined
·
32 Posts
Have under hood battery tested or replaced do you speak the language displayed and can you translate for us? Have codes pulled
Under hood battery tested through multimeter is 13.61 +....
I'm not able to understand the language message that is showing.
Have not got any codes while testing through diagnostic. I have to check with other diagnostic machine

After Translating the language. I got this...
63785
63786
 

·
Registered
Joined
·
32 Posts
How to match a 12v car battery under the hood. Currently is fitted 38B19L - MF.
In Fiji country we don't have this battery 38B19L. We mostly have NS40 like that etc...... Which battery is best and size for honda crz. I have checked Google it says NS40ZL is the right size. Any suggestions please?
 

·
Super Moderator
Joined
·
6,854 Posts
Multimeter check is useless especially if car is running, you need a load test. As for sizing any battery that is the same or larger CCA and fits can be used. Some have cut the battery tray to make a larger one fit. As long as the hold down secures it that will be sufficient. Anyplace that sells batteries has a table that gives equivalent batteries.

Take to some place that can read the codes and report back it would be good if they can translate what that light is stating in English.
Under hood battery tested through multimeter is 13.61 +....
I'm not able to understand the language message that is showing.
Have not got any codes while testing through diagnostic. I have to check with other diagnostic machine
 
181 - 200 of 217 Posts
Top