Honda CR-Z Hybrid Car Forums banner
1 - 9 of 9 Posts

· This space deliberately left blank
Joined
·
2,556 Posts
I dont have any 7.5 mA fuses so Im running down to the auto parts store... God if this was it the whole time that would be a fu***ng miracle. Trying to not get my hopes up though...

Edit: Just had a thought/question. If a fuse isnt seated properly could that cause something electrical to fry out? The point of fuses is for them to fry first, right? *not electrically inclined*
I wouldn't get your hopes too high. usually a fuse blows because of a fault. if the fuse is mis-seated so that it bridges both contacts with a blade of the fuse then yes, it could blow accessories out, but I don't think that's physically possible with this style of fuse mount.

If it's killing the radio fuse, I'd start looking at all the aftermarket components. from what I think you've posted in teh past about this car here and on facebook, it looks like a lot of **** was hacked up on the installs from a previous owner.
 

· This space deliberately left blank
Joined
·
2,556 Posts
My boyfriend reminded me to check the back up fuse. I did and it looked corroded so I replaced it. Didnt change anything but at least theres a fresh one in there.

Might as well check them all right now and worry about Hondata later. Might need to get a bigger fuse kit! <img src="http://www.crzforum.com/forum/images/smilies2/lol.gif" border="0" alt="" title="Lol" class="inlineimg" />

Edit: All the fuses I pulled so far look corroded. Moisture? I might as well replace them all! Harbor Freight trip is in order. I just got a 20% off coupon in the mail today heh. ItÂ’s a sign!
I've had corroded fuses cause problems before. nothing quite like fixing your dome light by scraping the oxide layer off a fuse.

I don't trust Harbor Freight fuses. had a couple blow well below their rated amperage, so I threw out the rest of the box. Also the plastic is pretty brittle.
 

· This space deliberately left blank
Joined
·
2,556 Posts
Currently its undergoing body modifications. He wants to keep it a secret until the dragon meet for a big reveal!
Well shoot, now I have to go!

Oooh, oooh, oooh, I think I know what that is! Was supposed to keep it a secret, so I forgot all about it, lol. :wink2:
he's gonna be like you with your lambo doors and just show up and flex.
 

· This space deliberately left blank
Joined
·
2,556 Posts
@HondaHolly It really sounds as simple as "you've got a damaged ground or feed" on the B1 circuit. At this point I'd say feed since you lose the WHOLE circuit at once. if it was a bad ground, it would be either wider spread than that, or more isolated than "Everything on that circuit"

All the symptoms you've described are on that Circuit.

Could also be a fried MICU. Have you ever had the car jump-started? Might want to see if @d1giPhux is willing to pull the MICU...
 

· This space deliberately left blank
Joined
·
2,556 Posts
So you need one of these? Or the fuse box? I got one for a 2011 6MT.. still parting my car out. I would need to figure out what the part looks like, then could pull it.

Let me know. Hit me up via pm or my name @ hotmail.com.
Looks like it has to be a cvt micu of the same trim level (I also know she got one already to match), so yours wouldn't work.
 

· This space deliberately left blank
Joined
·
2,556 Posts
I've owned my black crz for 9 years and the god awful windshield whistle got worse over the last year and I think its time I actually do something to fix it 😅 Its so bad now my radio cannot block out the sound and on very heavy rains I get 3 spots over the passenger side where water drips down the INSIDE of the winshield heh...
that means you've got some actual separation of the butyl sealant... you'll want to call safelite or something and see if they will R&R the glass just to reseal it.
 
1 - 9 of 9 Posts
Top