Honda CR-Z Hybrid Car Forums banner
441 - 460 of 525 Posts

·
Registered
Joined
·
905 Posts
Discussion Starter · #441 ·
Ohh I know all about LHT, was the place I was considering once I had the funds....also for a short time their KR-Z was for sale near me but the place wanted $25k.
If you have the funds... Might ship to them and they ship back when done...
 

·
Registered
Joined
·
462 Posts
If you have the funds... Might ship to them and they ship back when done...
First things first, getting a better paying job (not getting K anything on $10.33/hr), then getting a 2nd mode of transportation (thinking Can-Am Spyder F3-S).
 
  • Like
Reactions: Fediej

·
Registered
Joined
·
905 Posts
Discussion Starter · #443 ·
First things first, getting a better paying job (not getting K anything on $10.33/hr), then getting a 2nd mode of transportation (thinking Can-Am Spyder F3-S).
Get a beater Civic... Then you can send the "precious" to get turboed. You'll love that turbo woooossshhh.
 

·
Registered
Joined
·
462 Posts
Get a beater Civic... Then you can send the "precious" to get turboed. You'll love that turbo woooossshhh.
woooooooooo....psh....woooooooooo....psh!
 
  • Like
Reactions: Shamarskii

·
Registered
Joined
·
905 Posts
Discussion Starter · #445 ·
Just for comparison... Here's what my straight pipe Mustang sounds like compared to the Sprintex Z...https://photos.app.goo.gl/iajWuJLy1HKMpWVW7
 
  • Like
Reactions: CuteZ

·
Registered
Joined
·
905 Posts
Discussion Starter · #447 ·
Link didn't work for me, You straight-piped your ecoboost?
Yeah. Too quiet for me. It sounds good. It delivers great power. About 340 crank HP.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #449 ·
Did an oil change on Saturday. This is what greeted me when I took the aluminum panel off. Found a used low miles CV axle from LKQ for $98. Honda wants $600 for a new one. I will make this a diy project.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #450 ·
Adding some innovative motor mounts with 60A bushings to the Z. I've got some wheel hop that I'd like to eliminate. Mostly notice it on hard launches. This should also help the car handle sharp corners better.
 
  • Like
Reactions: litz

·
Registered
Joined
·
905 Posts
Discussion Starter · #451 ·
Sending my blower off the JB performance for an oil consumption kit and a sight glass install. I initially had scheduled for a shop to remove and install it for $900 but got bored the other day. Wasn't as bad as I thought. Have lots of loose hardware in a ziplock bag. Hopefully reinstalling will be just as painless.
 
  • Like
Reactions: Spdbump

·
Registered
Joined
·
905 Posts
Discussion Starter · #452 ·
Blower is back on the car and she runs super smooth. She fired up right away. I've also got a smaller pulley ready to install. Just have to find a cooling solution for combustion temps and a 2 bar MAP sensor.
 

·
Registered
Joined
·
42 Posts
Blower is back on the car and she runs super smooth. She fired up right away. I've also got a smaller pulley ready to install. Just have to find a cooling solution for combustion temps and a 2 bar MAP sensor.
From whom did you order the smaller pulley from?
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #454 ·

·
Registered
Joined
·
905 Posts
Discussion Starter · #455 ·
Finally getting my rear engine mount from Innovative installed tomorrow. Shouldnt be too difficult to install.
 
  • Like
Reactions: Spdbump

·
Registered
Joined
·
905 Posts
Discussion Starter · #456 ·
CVT is officially toast. Redlined on the highway cruising then it wouldn't accelerate anymore. My guess is either the belt snapped or the start clutch went out.
 

·
Premium Member
Joined
·
6,156 Posts
CVT is officially toast. Redlined on the highway cruising then it wouldn't accelerate anymore. My guess is either the belt snapped or the start clutch went out....
Oh no--sorry to see it go poof! That's something that's never given me a sign of eminent failure, but is it one minute good, and the next gone, with no warning?
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #458 ·
It was completely unexpected. No warning signs. It started and drove fine in the morning. Car still runs but won't move in drive or reverse. I'm thinking either the belt or start clutch broke.
 

·
Super Moderator
Joined
·
7,363 Posts
When my Crank Position Sensor failed I thought my transmission was dead as it would not move under its own power. Same result car on flat bed taken to shop. I had a clue due to code from the Scan Gauge II. Are you sure it is the Transmission? Either way it needs a visit to a shop to find out what is broken then you have to decide next steps.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #460 ·
When my Crank Position Sensor failed I thought my transmission was dead as it would not move under its own power. Same result car on flat bed taken to shop. I had a clue due to code from the Scan Gauge II. Are you sure it is the Transmission? Either way it needs a visit to a shop to find out what is broken then you have to decide next steps.
I checked for codes with my scan tool. No codes and "check transmission" message is gone.
 
441 - 460 of 525 Posts
Top