Honda CR-Z Hybrid Car Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
478 Posts
Discussion Starter #8
and I thought I was up there at 200k Have you replaced your IMA battery yet?

and I thought I was up there at 200k Have you replaced your IMA battery yet?


Nope it’s running strong. At around 240,000 miles I replace the catalytic converter. At 250,000 miles aI replaced the front and rear shocks and springs and the original brake pads from the factory. I also bought a set of four Perelli tires.
 

·
Registered
Joined
·
51 Posts
Nope it’s running strong. At around 240,000 miles I replace the catalytic converter. At 250,000 miles aI replaced the front and rear shocks and springs and the original brake pads from the factory. I also bought a set of four Perelli tires.
WOW good job! My clutch is being replaced next week. I did struts and shocks at 140k and am on my 4th or 5th set of pads. the only other problem I have had was under hood battery at 100k and then 180k.
 

·
Registered
Joined
·
478 Posts
Discussion Starter #10
WOW good job! My clutch is being replaced next week. I did struts and shocks at 140k and am on my 4th or 5th set of pads. the only other problem I have had was under hood battery at 100k and then 180k.


Yeah I’ve replaced that battery twice as well.
 

·
Registered
Joined
·
142 Posts
I am trying to catch up to you, just hit 225K, still on the original brake pads because its mostly highway miles. I had them checked to be sure last oil change, and they were still good. Replaced the 12V battery in Feb also for the first time.
2013 EX 6MT, bought Aug 13.
 

·
Registered
Joined
·
478 Posts
Discussion Starter #17
I am trying to catch up to you, just hit 225K, still on the original brake pads because its mostly highway miles. I had them checked to be sure last oil change, and they were still good. Replaced the 12V battery in Feb also for the first time.

2013 EX 6MT, bought Aug 13.


It won’t take that long. With me working from home now the mileage isn’t adding up as quickly. Currently at 253,856.
 

·
Super Moderator
Joined
·
5,945 Posts
Did you replace the battery because they died ? I believe mine is original since 2014 and it’s been 4 years now....
Two words Load Test and know for sure or wait till you have mystery electrical issues. Make sure if you get it load tested it is either out of the car or the car is not running. Many car parts places will test for free.:nerd:
 

·
Registered
Joined
·
599 Posts
Two words Load Test and know for sure or wait till you have mystery electrical issues. Make sure if you get it load tested it is either out of the car or the car is not running. Many car parts places will test for free.:nerd:


Great tip ! Heck, I might get a load tester myself since I have other cars at home too :D
 
1 - 20 of 26 Posts
Top