Honda CR-Z Hybrid Car Forums banner
1 - 2 of 2 Posts

·
Registered
2011 CR-Z EX
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
Hey all,

I bought my CR-Z about 2 months ago, but I’ve only had it in my possession for a month. CarMax and Honda have had it now for over a month, and they’re failing to replicate an A/C issue I’ve had every time I get into the car.

The a/c would blow cold air for maybe 10-15 minutes before it isn’t cold anymore. I'd shut it off, and after a little while it might decide to blow cold again, only for it to stop shortly thereafter. To me it sounds like the compressor, but again, both dealerships haven’t been able to replicate it.

Any idea on what problem could’ve miraculously sorted itself out? I just want my car back, but I think I’ll go insane if I pick it up and have the same issue after getting it back.
 

·
Registered
Joined
·
161 Posts
Two things,

Expansion valve is not working correctly

Or there is water in the system causing ice to form in the expansion valve

I am working on this with my 11 right now. I know it is not the compressor as that was changed to the larger 90cc unit that was on the K series I swapped in. Problem was there before and after the swap eliminating the compressor.

I am seeing very low low side pressures and extremely high high side pressure. Points to an issue with the expansion valve.

I have a new desiccant sock and expansion valve that just arrived and should be able to get those installed soon.

And I know it is not correct because the 12 I had for a short period felt like it had 10 times the cooling capacity.
 
1 - 2 of 2 Posts
Top